vSphere 7 támogatás HPE szervereken

A vSphere 7 és annak minden benne foglalt komponense mint a vCenter Server, a vSphere ESXi 2020. április 2-án lépett a “Generally Available” – GA – fázisba. Ez a vanilla ESXi kiadást jelenti, a gyártók-e dátum előtt jó eséllyel már rendelkeznek a GA kódú kiadással, hogy felkészülhessenek azokkat a speciális kiadással, amelyek tartalmazzák az általuk gyártott szerverekhez a megfelelő driver-eket és egyéb kiegészítőket.

Nyilvánvalóan vannak olyan ügyfelek, ahol az N-1 verziót kell produktív üzemben használni, ugyanakkor léteznek olyan funkciók amik legitimálják a legújabb verzió telepítését.

Ilyen rögvest a VMware Cloud Foundation 4. Már az, hogy valaki ilyet szeretne, megköveteli a vSphere 7-et, na és ha még a vSphere 7 integrált Kubernetes is kívánt, akkor végképp kötelező. De he az túl elrugaszkodott, akkor a VMware NSX-T 3.0, VMware Distributed Switch támogatása is megköveteli a vSphere 7-et, mert vDS 7.0 kell hozzá.

Általában a gyártók igyekeznek nagyon gyorsan támogatottá tenni egy olyan szoftvert mint a VMware vSphere ESXi. A HPE sem pazarolta az időt és a legtöbb szervernél igen gyorsan, heteken belül támogatni kezdte, viszont a blade formátumú “új” platformján, a Synergy-n nem lett támogatott.

Mivel nekem elsősorban Synergy-n van lehetőségem tesztelni, hetente nézegettem a VMware HCL-t hátha feltűnik. Végül június 16-án megjelent. Ki is tettem Twitter-re, annyira megörültem. A Synergy Gen10-en vált támogatottá.

Aztán rá pár napra eltűnt a HCL-ről. Azért nem adtam fel, azt gondoltam valamilyen adminisztrációs hiba következménye lehetett, letöltöttem az ISO-t, feltettem VUM – VMware Update Manager – és rögvest jelezte nekem, nem kompatibilis. Jelzem, ebben a pillanatban az összes – mainstream Proliant szerveren támogatott volt már, még a kifutó c7000 keretbe tehető BL szervereken is.

Annyit tudtam meg, hogy valami baj van pár driver-rel – a RAID-vezérlőé is bajos – emiatt visszavonták és augusztus végére halasztották. Ez a nekem való történet, hangot is adtam egy fórumon neki, ahol úgy ujjbegyről elkültek a melegebb éghajlatra, hogy miért akarna bárki vSphere 7-et használni ha az egy “bugokkal teli” szoftver. Hát ezt ne a gyártó döntse el miért akarná valaki a “bugos” terméket használni, főleg úgy hogy minden más gyártónál már alapból támogatott.

Aztán három napja feltűnt a HCL-en megint, ekkor érdekes módon a Gen9 vált kompatibilissé, a Gen10 pedig nem. Szóval pont fordítva mint júniusban.

Ez egy újabb build, gyorsan le is töltöttem, feltettem VUM-ba és kompatiblilitást jelzett a Gen9-es szervereken.

Már telepítettem is fel két Gen9 blade-re, minden zöld, minden rendben. A fentebb említett fórumon azért többen jelezték neheztelésüket ezzel a várakozással kapcsolatban. A fenti képet posztoltam és azt, hogy én feltettem már két Gen9 szerverre és minden oké.

Ekkor megint elküldtek melegebb éghajlatra mert az állítás szerint: a VMware HCL nem hivatalos! Tehát ami ott található, az a HPE szerverekre nem vonatkozik, a kompatibilitást csak itt lehet ellenőrizni: https://techlibrary.hpe.com/us/en/enterprise/servers/supportmatrix/vmware.aspx

Ma 2020. augusztus 8-án a VMware HCL szerint támogatott a HPE Synergy 480-as szerveren a vSphere ESXi 7. A HPE oldala szerint pedig nem.

Mást állít a VMware HCL és mást a HPE oldala. Gondoltam megkérdezem, hogy akkor a VMware-nek mégis ki mondja meg, hogy a HCL-ben kattintsák be egy adott kiadás támogatását. Azt kaptam, hogy azt bizony HPE-s ember mondja, aki nem tagja a Synergy-t feljesztó csapatnak – vagy valami hasonló.

Őszintén szólva egyáltalán nem érdekel mi az oka. 10-ből, 10 ember a VMware HCL-t nézi, ahogyan azt teszi például a VSAN-nal kompatbilitis RAID/HBA vezérlők, az SSD-kkel kapcsolatban is, nem a gyártó oldalát, tehát a VMware HCL a de facto authentikus forrás. És itt a kivétel.

Szóval ha HPE kiszolgálód van, akkor neked csak a HPE oldala – ez – a megbízható forrás ha vSphere-ről van szó. Ha VSAN-ról, akkor a VMware HCL a hivatalos. Nem tartom elfogadhatónak ezt a kettősséget, sem azt, hogy a next gen platform így 4 hónap után sem bír vSphere 7-et futtatni.